WordPress基础教程

如何解决升级到WordPress 5.5后导致js报错和网站功能不正常

发布时间:2020-08-23 10:07:20

本文作者:

有些朋友可能会发现,升级到WordPress 5.5以后,网站的某些功能不正常了,通过浏览器调试工具查看,会发现一些js报错,比如 提示js函数 .live 不存在之类的。

其实主要的原因是,正如《WordPress 5.5 正式版发布》提到的:

WordPress 5.5删除了jQuery Migrate1.x。对于使用jQuery的开发人员来说,这是一个问题。如果使用jQuery,请确保您不依赖jQuery Migrate 1.x单独提供的任何功能。

也就是说,有些主题或插件使用了比较老旧的jQuery函数,以前一直都采用jQuery Migrate1.x做兼容处理的,但是现在WordPress 5.5+ 默认禁用了这个兼容库,所以就出现问题了。

如何解决升级到WordPress 5.5后导致js报错和网站功能不正常

对于开发者来说,应该尽快更新自己的产品代码,尽可能使用新的jQuery函数。解除对jQuery Migrate1.x的依赖。开发者指南

对于大多数的普通用户来说,肯定是无法去自己修改代码做兼容处理的,怎么办?

其实WordPress官方团队早就想到了这个问题,专门开发了一个小插件 Enable jQuery Migrate Helper,只需要安装和启用插件,就可以继续加载 jQuery Migrate1.x,让你的网站避免出现js错误。

不过,建议普通用户可以联系一下主题和插件作者,提醒他们更新代码,这样才是最好的做法。

小兽wordpress凭借多年的wordpress企业主题制作经验,坚持以“为用户而生的wordpress主题”为宗旨,累计为2000多家客户提供品质wordpress建站服务,得到了客户的一致好评。我们一直用心对待每一个客户,我们坚信:“善待客户,将会成为终身客户”。小兽wordpress能坚持多年,是因为我们一直诚信。我们明码标价(wordpress做网站需要多少钱),从不忽悠任何客户,我们的报价宗旨:“拒绝暴利,只保留合理的利润”。如果您有网站建设、网站改版、网站维护等方面的需求,请立即咨询右侧在线客服或拨打咨询热线:18907337671,我们会详细为你一一解答你心中的疑难。

相关文章

写给所有互联网营销朋友的一封信

写给所有互联网营销朋友的一封信

2020年,我希望和更多的朋友,更多的营销从业者一起探讨企业的互联网营销。我想要所有的人都可以以最低的成本进去互联网,并且以最快的效率去做互联网营销。如果你也有兴趣和激情做互联网营销,请让我们并肩同行。

点击查看详情

准备开启WordPress网站建设推广?

我们相信高端漂亮的网站不应该是昂贵的,这就是wordpress对每个人都是免费的原因
wordpress建站免费入门,并提供价格合理的wordpress建站套餐。